Une date?
Pascal Coulougnon

Une date?

#1
Salut,
Vous auriez eu vent d'une date approximative de sortie pour la 2.5.11 en version finale?

Car j'ai l'impression que tout le monde bosse dur dessus et du coup, les modules sont testés et débogués pour la version 2.11, et plus pour pour la version 2.10.

J'en suis à me demander s'il ne vaudrait pas même mieux directement tenter de sortir un site sous 2.5.11 dans mon cas puisque newbb (qui est mon module principal) semble parfaitement fonctionner sous 2.11 et pas avec les fonctions dont j'ai besoin sous 2.5.10.

J'ai une petite idée de la réponse à cette dernière idée... mais je ne peux pas utiliser un xoops 2.5.10 en l'état actuel et suis dans l'obligation de rester sur mon vieux 2.5.7 qui lui ne me permet plus d'intégrer les nouveaux modules.

Du coup je suis à ce jour totalement bloqué.
Re : Une date?
Alain T

Re : Une date?

#2
Alain T 167
3/30 8:56
Hummm,
je préfère que Greg s'y colle et te réponde...

Re : Une date?
Grégory M

Re : Une date?

#3
Grégory M 56
3/30 9:12
Salut,

Pour la version finale, nous n'avons pas de date. Je ne pense pas que celle-ci sera disponible avant l'été.

Concernant tes besoins, normalement tous les modules fonctionnent sur XOOPS 2.5.10. Je ne vois pas vraiment ce qui peut bloquer dans ton cas, as tu plus de précision?

Concernant l'installation d'une version en cours de développement, cela est toujours risqué. Nous déconseillons donc de le faire. Pour informations nous ne respectons pas cette directive car ce site en en 2.5.11...
--------------------
www.monxoops.fr
Re : Une date?
Pascal Coulougnon

Re : Une date?

#4
Merci Greg,

j'ai absolument besoin de pouvoir poster plusieurs pièces jointes dans un même post, j'ai détaillé mon soucis ici : https://www.monxoops.fr/modules/newbb/viewtopic.php?topic_id=26

Mais pour t'épargner mon post, voici le résumé de mon soucis avec newbb :
- 5.00 final, une seule pièce jointe est acceptée par post. si on en envoie une seconde elle supprime la première.
- 5.01 Beta 4, on peut en envoyer plusieurs, mais on ne peux pas les récupérer.
- 4.33 RC9 installé sur mon site de prod actuel (sous 2.5.7) non compatible 2.5.10 (et de toute manière me posera des soucis plus tard).

Tout le monde semble tester newbb 5.01 Beta 4 sur xoops 2.5.11 sans rencontrer mon soucis, mais personne ne teste sur 2.5.10, je ne suis donc pas tout à fait certain que ce problème soit commun à tout le monde.

Dès que j'ai un moment je vais déjà tester une install en 2.5.11 pour m'assurer que ça corrige bien ce problème.
Mes autres modules seront xmdoc ; xmnews & wggallery qui semblent tous optimisés pour 2.5.11 eux aussi.

Du coup, je me disait que s'il est possible ensuite de faire des upgrade depuis un 2.5.11 actuel vers une version finale plus tard, ma solution serait peut être là.
Re : Une date?
Alain T

Re : Une date?

#5
Alain T 167
3/30 10:02
Indique bien dans ton "issue" que tu es en 2.5.10.
L'idéale est que tu détailles bien ta version de XOOPS (php ?/myql ?) et que tu donnes le cheminement exact pour atteindre le problème que tu rencontres.
Re : Une date?
Pascal Coulougnon

Re : Une date?

#6
Pascal Coulougnon 144
3/30 10:41
Fait, merci.
Re : Une date?
Alain T

Re : Une date?

#7
Alain T 167
3/30 11:14
Re : Une date?
Pascal Coulougnon

Re : Une date?

#8
Pascal Coulougnon 144
3/30 16:42
Bon, les pièces jointes fonctionnent parfaitement avec newbb & xoops 2.5.11
Peut être que cela est dû au fait d'être passé de PHP 7.3 vers 7.4 qui n'était pas toléré par Xoops 2.5.10 !!?

Bref, je crois vraiment que je vais opter pour cette solution qui semble être la seule qui s'ouvre à moi. Depuis que je me prends le chou là dessus...

Est-il possible d'upgrader une version beta vers la version stable de la même manière que l'on upgraderait un 2.5.10 vers 2.5.11 ou bien ça coince ?

Si oui, le risque est très limité finalement et je ne peux que me retrouver avec des bugs mineurs qui seront corrigés lors de la version définitive.
Re : Une date?
Alain T

Re : Une date?

#9
Alain T 167
3/30 17:22
Quote:
Est-il possible d'upgrader une version beta vers la version stable de la même manière que l'on upgraderait un 2.5.10 vers 2.5.11 ou bien ça coince ?
Ben voila, c'est là où il faut être prudent...

Il n'y a aucune MAJ de XOOPS 2.5.11 beta vers une version finale.
Il faudra "écraser" c'est à dire bien comprendre ce que tu vas faire.

Ce n'est, bien sur pas impossible, mais il faut tout maîtriser pour éviter certains effets de bords tels que ceux présentés ici :
Don't overwrite configuration data on upgrades.

Greg pourra peut-être compléter.
Re : Une date?
Pascal Coulougnon

Re : Une date?

#10
Pascal Coulougnon 144
3/30 18:07
Ha, c'était trop facile... du coup c'est pas vraiment pour moi ça

Il sera probablement moins risqué de carrément faire un backup de ma Beta & remonter un 2.5.11 final propre et neuf du coup à mon niveau, plutôt que de bidouiller.

Bon, va falloir que je réfléchisse bien, avant quoi que ce soit du coup.

Merci Alain