XOOPS 2.5.11 version finale

1575
Auteur
Alain
Publication
29-12-2023 10:20
29-12-2023
Mise à jour
29-12-2023
Note: 0.0 (0 vote)
XOOPS 2.5.11 version finale

XOOPS 2.5.11 version finale

L'équipe de développement de XOOPS a le plaisir d'annoncer la sortie de XOOPS 2.5.11 en version finale.

Cette version de production amène :
- Plus de 500 améliorations et corrections depuis XOOPS 2.5.10,
- Plus de 80 améliorations et corrections depuis XOOPS 2.5.11 RC3.

Voici une très courte liste :

  • Compatibilité PHP 8.0 PHP 8
  • Compatibilité MySQL 8.0 MySQL 8
  • Utilisation de Smarty 3 Smarty 3
  • La copie d'une nouvelle version de XOOPS n'écrase pas les fichiers de configuration existants
  • Nouveau thème xSwatch4 basé sur Bootswatch lui-même basé sur la librairie CSS Bootstrap
  • Capacité de surcharge des modèles dans les thèmes de l'administration système
  • Mises à jour de sécurité
  • Mises à jour des librairies
  • Et bien d'autres corrections et mises à jour
La liste complète des changements se trouve ici.

XOOPS 2.5.11 introduit un changement significatif : Smarty 3, le moteur de templates.
Malheureusement, ce changement peut potentiellement perturber certains thèmes plus anciens.
Par conséquent, avant de procéder à la mise à niveau, veuillez vous assurer de suivre les étapes suivantes :
  • Copier le répertoire upgrade dans le répertoire racine de votre XOOPS
  • Exécutez /upgrade/preflight.php pour vérifier s'il y a des thèmes ou des templates de modules obsolètes.
  • Si des problèmes sont identifiés, consultez ce document pour comprendre les modifications nécessaires avant de procéder à la mise à niveau.
  • Après avoir effectué les modifications nécessaires, exécutez à nouveau /upgrade/preflight.php.
  • S'il n'y a plus de problèmes, vous pouvez commencer le processus de mise à niveau.

22 contributeurs ont œuvré pour améliorer notre CMS, XOOPS !
En voici 7 :

...
geekwright
...
mambax7
...
GregMage
...
alain01
...
luciorota
...
zyspec
...
ggoffy

Vous pouvez constater que 2 contributeurs parmi les 7 sont webmasters de monxoops.fr !

Pré-requis

Recommandations
XOOPS 2.5.11 finale

Minimum requis

Recommandé

Compatible
PHP PHP 7.1 PHP 7.4 PHP 7.4+, PHP 8.1x
MySQL
MariaDB compatible
MySQL server
5.6
MySQL server
8
MySQL server
8.0+
Serveur Web
Apache, NGINX...
Doit supporter des scripts PHP


Nous vous conseillons de lire avec attention les 2 tutoriels suivants : Vous pouvez aussi lire le manuel d'installation et de mise à jour de XOOP, en anglais.

Traduction française pour XOOPS 2.5.11

Traduction française pour XOOPS 2.5.11

Télécharger


XOOPS 2.5.11 Fr

XOOPS 2.5.11 Fr

Télécharger


Options d'affichage des commentaires :       
Les commentaires sont la propriété de leur auteur. Nous ne sommes pas responsables de leur contenu.
Auteur
Discussion
Publié 29-12-2023 12:58
 
  • Administrateur

 Re : XOOPS 2.5.11 version finale

N'hésitez pas à commenter cette nouvelle!
Utilisez le forum pour vos questions.