xmcontent 1.6 Stable
Grégory M
Grégory M

xmcontent 1.6 Stable

Grégory M 135
29/01 18:11
#1
Grégory M 135
29/01 18:11
J'ai le plaisir de vous annoncer la sortie de la version 1.6. Cette version est une version stable pour un site en production!

Pour les informations et le téléchargement, c'est par ici:

Fiche xmcontent

Le changelog est disponible sur cette même page
--------------------
www.monxoops.fr
Re : xmcontent 1.6 Stable
Nicolas
Nicolas

Re : xmcontent 1.6 Stable

Nicolas 65
09/10 10:48
#2
Nicolas 65
09/10 10:48
Slut,

J'ai trouvé un petit soucis deans le module ligne 287 de admin/content.php
Actuellement, après la sauvegarde cela retourne une erreur en version test, genre localhost/xoops, on se retouve sur localhost...
Voici la ligne pour corriger :
$error_message $obj->saveContent($contentHandlerXOOPS_URL '/modules/xmcontent/admin/content.php?fcontent_status=' $fcontent_status '&title=' $title);


Autre petite chose, $title est toujours vide dans ce cas aussi(ps forcement utile, non ?)

Nicolas
Re : xmcontent 1.6 Stable
Grégory M
Grégory M

Re : xmcontent 1.6 Stable

Grégory M 135
09/10 15:06
#3
Grégory M 135
09/10 15:06
Salut Nicolas,

Je ne comprends pas, cette ligne permet de faire la sauvegarde. Donc si il y a une erreur lors de la sauvegarde, cela peut venir de ta bdd. Dans mes tests je n'ai pas de problème.
$title n'est pas toujours vide, cela dépend si tu as activé un filtre avant (cela permet de garder le filtre après sauvegarde et d'afficher juste ce que tu voulais).

C'est quoi le message d'erreur?
--------------------
www.monxoops.fr
Re : xmcontent 1.6 Stable
Alain T
Alain T

Re : xmcontent 1.6 Stable

Alain T 555
09/10 15:38
#4
Alain T 555
09/10 15:38
@Greg
As tu essayé de tester avec un site qui n'est pas à la racine ?
https://monsite_a_moi.fr/test
?

@Nicolas
Pour le titre,
as tu bien compris le fonctionnement du filtre ?

Alain
Re : xmcontent 1.6 Stable
Grégory M
Grégory M

Re : xmcontent 1.6 Stable

Grégory M 135
09/10 15:41
#5
Grégory M 135
09/10 15:41
Non pas testé mais je ne vois pas pourquoi cela ne fonctionnerait pas. Je fait pareil pur tous les modules. XOOPS_URL doit contenir le bon chemin...
--------------------
www.monxoops.fr
Re : xmcontent 1.6 Stable
Nicolas
Nicolas

Re : xmcontent 1.6 Stable

Nicolas 65
14/10 14:14
#6
Nicolas 65
14/10 14:14
Citation :

Grégory M a écrit :
Salut Nicolas,

Je ne comprends pas, cette ligne permet de faire la sauvegarde. Donc si il y a une erreur lors de la sauvegarde, cela peut venir de ta bdd. Dans mes tests je n'ai pas de problème.
$title n'est pas toujours vide, cela dépend si tu as activé un filtre avant (cela permet de garder le filtre après sauvegarde et d'afficher juste ce que tu voulais).

C'est quoi le message d'erreur?


La ligne permet de corriger le problème, en faite il manque XOOPS_URL du coup on retombe à la racine du site.

Nicolas
Re : xmcontent 1.6 Stable
Grégory M
Grégory M

Re : xmcontent 1.6 Stable

Grégory M 135
14/10 22:56
#7
Grégory M 135
14/10 22:56
Moi je regarde ton post et je me dit que tout est ok... Merci pour le retour car il manque effectivement XOOPS_URL.

Apparemment, j'ai le problème dans pas mal de mes modules... Un peu de travail en perspective.
--------------------
www.monxoops.fr